Veröffentlicht am 1 Kommentar

WordPress: In diesem Block ist ein Fehler aufgetreten…

Manchmal ist WordPress nervig. Vor allem dann, wenn es einem Fehlermeldungen ausspuckt, mit denen man nichts anfangen kann. Was war passiert: Nach einem Update ließ sich der Editor (aka Gutenberg) nicht mehr nutzen. In diesem Beitrag erkläre ich dir, wie du ihn wieder zum Laufen bringst.

Updates bei WordPress führen manchmal zu großen Problemen, deren Ursache nicht sofort klar ist. So auch in diesem Fall. Unmittelbar, nachdem ich die Version 5.4 installiert habe, konnte ich keine Beiträge mehr verfassen. Immer, wenn ich einen neuen Artikel anlegen wollte, zeigte mir WordPress die Fehlermeldung „In diesem Block ist ein Fehler aufgetreten und eine Vorschau ist nicht möglich“ (oder auf Englisch: „This block has encountered an error and cannot be previewed“).

Es hat mich ein paar Stunden gekostet, um herauszufinden, woran das liegt. Verursacht wird der Fehler durch WordpPress-Erweiterungen, die noch nicht mit dem neuen 5.4 kompatibel ist. Zunächst solltest du also gucken, ob alle deine Plugins und Themes auf dem neuesten Stand sind und/oder bereits Updates vorliegen. Eine Aktualisierung meiner Plugins hat das Problem bei mir schnell gelöst.

Hier kannst du in deinen Profileinstellungen den Haken bei „Beim Schreiben den visuellen Editor nicht benutzen“ setzen

Sollten alle deine Plugins auf dem neuesten Stand sein oder (noch) kein Update vorliegen, gibt es mehrere Lösungsmöglichkeiten. Du kannst in deinen Profileinstellungen den Haken bei „Beim Schreiben den visuellen Editor nicht benutzen“ setzen. Um einfache Texte zu posten, ist das sicherlich ganz ok. Willst du deine Beiträge allerdings mit Grafiken, Fotos oder Videos anreichern, bringt das nicht viel. In diesem Fall solltest du das Plugin für den klassischen Editor installieren und solange nutzen, bis dein Problem durch ein WordPress- Plugin- oder Theme-Update gelöst wird.

Teile diesen Beitrag

1 Gedanke zu „WordPress: In diesem Block ist ein Fehler aufgetreten…

  1. Huhu Matthias.

    Hatte heute zum ersten Mal das selbe Problem. Bin noch recht neu mit WordPress. Konnte das über die PlugIns nicht lösen, weil es da noch keine Aktualisierungen gibt und ganz oben rechts beim Rad bei den 3 Punkten hab ich im Beitrag nachdem ich z.B. ein Audio eingefügt habe (wo die Fehlermeldung darauf dann direkt folgte) gewechselt auf „Code-Editor“ und dann direkt wieder zurück auf den „Visuellen Editor“ und es klappt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.